Help - Search - Members - Calendar
Full Version: Concerning C&C3 on Vista x64 and a sound driver
The Hotfix Share > Microsoft Operating System Discussion and Support > Windows Vista

Shoonay
I'll try to make it short as possible:

1. Got Vista x64 from the officiall beginning (february 2007, so pre-SP1 "era" wink.gif)
I had no probs with my soundcard in Vista x64 and I've enjoyed it much better than before, when I had XP used to switch my 5.1 speakers to stereo. Vista not only remembers the 5.1 setting but also does a great job at filling all the speakers even if the sound is only stereo.
I've frequently updated my AC'97 mobo soundcard's driver, every time I saw a new one at Realtek's site, up to the latest: 6280
Never, ever, had any problem with any game nor a proggie.
That includes Command and Conquer 3 - Tiberium Wars (Kane Edition)

2. Installed Vista x64 with "build-in" SP1
No probs with that, sound worked like it used to - flawless.

3. Installed Command and Conquer 3 - Kane's Wrath
Problems started - my sound setup started acting wierd, the main voice that is suppose to be played in the center speaker is played in my subwoofer. Generally speaking, the center speaker was silent all the time - when in this game.
And no, switchin between subwoofer/center in the drivers setup nor windows sound properties didn't work too.
Everything else (foobar2000, Media Player Classic with AC3Filter) worked great - like it used to.

4. Searched on Windows Update and to my suprise, found an "updated" driver.
Downloaded.
Installed.
Restarted.
I've set my speakers to 5.1 in the Realtek sound manager - center speaker silent, no matter if switched with subwoofer.
Every proggie I've tried plays now only in the front 2 speakers, no more "filling" the sound.
Tried to set that up in Windows sound properties, got a warning:
QUOTE
Windows has detected that audio enhancements for the following
device are causing problems:

Speakers (Realtek AC'97 Audio)

Would you like to disable Driver Enhancements for this device?

[Yes] [No]

No matter what I choose, any change there doesn't do a thing.
Damn.

Any suggestions?
Anyone had a similar problem?

I mean, I'm positive to go back to that officiall driver that I've had no problems, but damn, why does M$ release buggy drivers oficially on Windows Update? :/
Shoonay
Alright, so cancel the C&C part, the game works fine, had connected an extra subwoofer to my Creative 5.1 setup and it "broke" the center speaker connection. Still M$'s driver does NOT work correctly...
Shoonay
By George! This cannot be!

M$ released a fully working Realtek AC'97 driver yesterday (the version is: 6285) that now only allows to edit the Enhancements but there's also no lag, crackle and pop effect while browsing, copying, or doing anything while listening to music!

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.