Printable Version of Topic

Click here to view this topic in its original format

The Hotfix Share _ Troubleshooting _ Very slow loading of links & sites - Window 7 Ultimate 64 bit

Posted by: Bozo77 Jan 31 2016, 12:14 AM

having a problem of super slow loading of links & programs with Windows 7 Ultimate 64 bit. Have Comcast Blast (receiving 85-95 Mbps) but it takes forever to get things to load. Any ideas??

Posted by: cgthamm Feb 1 2016, 11:57 AM

This could be many things; however, one thing I have found in common with many of my clients who complain that browsing is slow, is Flash Player. Go to http://www.adobe.com , and download and install the most recent version of Flash Player.

Posted by: xable Feb 1 2016, 08:42 PM

Indeed there are myriad of possible causes here. Because you say programs are also running slow I'd lean towards virus/malware or a failing hard drive. Also try checking your HDDs health and running a virus/malware scan.

Posted by: Bozo77 Mar 9 2016, 05:08 PM

Thanks for the suggestions. Sorry I took so long to get to them as I got side tracked by a hospital stay. I have scanned for both viruses and malware numerous times and came up with nothing. I did replace my hard drive too as I also suspected that could be the cause...nothing! I'm starting to lean towards my cable modem, wireless router or even Comcast's cable drop as it's not only my computer but also my wife's that is loading so slow. Even my laptop is acting the same way. Any thoughts along this line? I welcome all ideas as I'm running out of my own!

Posted by: GrofLuigi Apr 8 2016, 12:41 AM

Change DNS servers.

Posted by: Rosty Feb 22 2017, 06:50 PM

To which one?

Posted by: cgthamm Feb 22 2017, 07:33 PM

Although it won't improve your DNS lookup speed, you could always test with public DNS servers, such as Google's:

8.8.8.8

and

8.8.4.4

- cgthamm



Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)