The Hotfix Share

Welcome Guest ( Log In | Register )

3 Pages V   1 2 3 >  
Reply to this topicStart new topic
 kb2919355 Component Store corruption, Windows 8.1 / Server 2012 R2 April 2014 update
cgthamm
post Apr 15 2014, 01:51 AM
Post #1





Group: Hotfixer
Posts: 78
Joined: 25-September 07
Member No.: 6,596



Microsoft has released a huge update for Windows 8.1, which it refers to as the April 2014 update. It is a compilation of all updates and hotfixes for Windows 8.1 produced before March 2014, and is actually composed of five files: an Update (kb2919355) and four Feature Packs (kb2932046, kb2934018, kb2937592, and kb2938439). All are available from the Microsoft Download Center, by simply searching for kb2919355.

NOTE: On April 17, 2014, Microsoft revised the April Update to include kb2959977. This additional Update is also available from the Microsoft Download Center.

The April 2014 update provides sorely-needed and long-overdue improvements in Windows 8.1's stability and reliability. In my opinion, it brings Windows 8.1 to the level of Beta-quality software -- finally usable on a day-to-day basis, although still buggy.

One major problem with the April 2014 update is a bug where the Component Store can be corrupted. There are two scenarios of which you need to be aware:

1) If you have not yet installed kb2919355, you should, at an elevated Command Prompt, issue the following command:

dism /online /Cleanup-Image /ScanHealth

Should corruption be detected, you should (again at an elevated Command Prompt) type:

dism /online /Cleanup-Image /RestoreHealth

If Windows 8.1's Component Store is for whatever reason corrupted before you install the April 2014 update, you absolutely need to repair it before installing it, or a new bug in kb2919355 will make it impossible to repair the corruption -- ultimately resulting in the need to re-format.

2) If you have already installed kb2919355, you need to check if your Component Store is already corrupted, using the ScanHealth command as in scenario 1 above. If your Component Store is, in fact, corrupted, you need to then run the RestoreHealth command as above. If the RestoreHealth command reports that it is unable to repair the Component Store, you need to use System Restore to back out to a point before installing kb2919355, and then re-issue the RestoreHealth command. At that point it should be able to repair the Component Store. You may then re-install kb2919355 and should experience no further Component Store issues, so long as you DO NOT RUN:

dism /online /Cleanup-Image /StartComponentCleanup

After kb2919355 is installed, you MUST NOT use StartComponentCleanup, as that command actually CAUSES Component Store corruption.

I have reported this issue to Microsoft, and will update this post once they have made a hotfix available that corrects this problem.

This post has been edited by cgthamm: Apr 19 2014, 04:08 PM
Go to the top of the page
 
+
xable
post Apr 15 2014, 03:55 PM
Post #2





Group: Administrator
Posts: 3,052
Joined: 27-May 06
Member No.: 1



Nice one cgthamm. Must give 8.1 a try, did not like 8 at all.
Go to the top of the page
 
+
RonnieJP
post Apr 21 2014, 06:24 PM
Post #3





Group: Hotfixer
Posts: 11
Joined: 21-April 14
Member No.: 97,650



QUOTE (cgthamm @ Apr 14 2014, 06:51 PM) *
One major problem with the April 2014 update is a bug where the Component Store can be corrupted. There are two scenarios of which you need to be aware:

You may then re-install kb2919355 and should experience no further Component Store issues, so long as you DO NOT RUN:

dism /online /Cleanup-Image /StartComponentCleanup

After kb2919355 is installed, you MUST NOT use StartComponentCleanup, as that command actually CAUSES Component Store corruption.

I have reported this issue to Microsoft, and will update this post once they have made a hotfix available that corrects this problem.


Sorry for truncating your post to save space, but Thank You, Thank You, Thank You! for being one of the few to recognize this very serious issue.
I had no problem installing the 8.1 update per se, however shortly afterwards I ran Disk Cleanup including system files with windows updates. Then when I ran DISM /online /cleanup-image /scanhealth (or restorehealth), it said DISM failed with error 0x800f081f.

After much reading of various forums, and trying most everything to no avail, I restored my PC to a pre-update image and installed the updates again. This time I did not run Disk Cleanup, and the DISM commands showed no component store corruption. I then ran DISM /online /cleanup-image /analyzecomponentstore and it suggested that I do a cleanup. So, I ran DISM /online /cleanup-image/startcomponentcleanup and it failed saying the component store was corrupted. The DISM scanhealth or restorehealth gave me the same 0x800f081f error again. So, I again restored my pre-update image, ran windows update again. This time I only ran the DISM check, scan or restore health commands and they all completed without error.

So, it appears that if any command is run that tries to cleanup the component store, it corrupts it.


By the way, when I ran either Disk Cleanup or the DISM cleanup on my pre-update restored image, they ran fine and did not corrupt the component store.
So, while most of the posts seem to deal with the inability to install the KB2919355 updates, I believe that the component store corruption issue may be at the root of the problem and I'm very concerned that MS will recognize this and fix it. Like may others, I do NOT want to have to do a clean install or even a repair install. Microsoft should steer clear from these suggestions as it is clearly their fault. If a re-install is required, they'd better prepare to compensate their users for all the time they'll spend on re-installing all their programs and updates.
Go to the top of the page
 
+
SusanBradley
post Apr 24 2014, 08:15 PM
Post #4





Group: Hotfixer
Posts: 5
Joined: 24-April 14
Member No.: 97,653



Do you have the case number? Would you mind posting it so I can follow up and make sure that Microsoft is taking action here?
Go to the top of the page
 
+
RonnieJP
post Apr 25 2014, 01:13 AM
Post #5





Group: Hotfixer
Posts: 11
Joined: 21-April 14
Member No.: 97,650



QUOTE (SusanBradley @ Apr 24 2014, 01:15 PM) *
Do you have the case number? Would you mind posting it so I can follow up and make sure that Microsoft is taking action here?


I think that you were responding to the OP. I am not cgthamm, but I have had the exact same experience as the OP, except my system is 32-bit.
I do not personally have a case number with Microsoft, but I have seen your posts on the Microsoft Windows 8.1 forum, specifically the one I pasted here:

Attached Image


In addition to what I posted above on this thread, I would be happy to provide you any additional specifics of my situation if you think it will help.
Go to the top of the page
 
+
cgthamm
post Apr 25 2014, 12:57 PM
Post #6





Group: Hotfixer
Posts: 78
Joined: 25-September 07
Member No.: 6,596



QUOTE (SusanBradley @ Apr 24 2014, 04:15 PM) *
Do you have the case number? Would you mind posting it so I can follow up and make sure that Microsoft is taking action here?



Hi Susan,

My contact at Microsoft is Anthony Bartolo.

This is actually a very serious problem. Anything you can do to speed up a fix would be much appreciated.


- Chris

This post has been edited by cgthamm: Apr 26 2014, 06:29 PM
Go to the top of the page
 
+
SusanBradley
post Apr 25 2014, 07:53 PM
Post #7





Group: Hotfixer
Posts: 5
Joined: 24-April 14
Member No.: 97,653



Got it, thanks! I can repro it too.
Go to the top of the page
 
+
SusanBradley
post Apr 25 2014, 08:18 PM
Post #8





Group: Hotfixer
Posts: 5
Joined: 24-April 14
Member No.: 97,653



Case opened:
Support Request Number - 114042511393434
Go to the top of the page
 
+
RonnieJP
post Apr 25 2014, 08:27 PM
Post #9





Group: Hotfixer
Posts: 11
Joined: 21-April 14
Member No.: 97,650



Here's another thread with the same issue posted on one of the Microsoft Community forums:

http://answers.microsoft.com/en-us/windows...7d-298be85e7bc3

See the post by TusoraKsijveu (2nd on the page)
Go to the top of the page
 
+
SusanBradley
post Apr 28 2014, 06:07 PM
Post #10





Group: Hotfixer
Posts: 5
Joined: 24-April 14
Member No.: 97,653



Good news/bad news.
Good news is I can repro this on one VM that I have. Bad news is I cannot repro this on a clean VMs. I've tried with and without MS office 2013 So I cannot repro at will :-( What is your exact environment?
Go to the top of the page
 
+

3 Pages V   1 2 3 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 8th December 2019 - 10:23 AM
All trademarks mentioned on this page are the property of their respective owners
The Hotfix Share is not affiliated with Microsoft
Copyright © 2019 TheHotfixShare.net